Research Log of Web Science Students

Computer Science is not simply programming

Posts Tagged ‘eclipse

Google App Engine: NoClassDefFoundError on run

leave a comment »

Everytime I try to run my project, I get the following error message:

Exception in thread “main” java.lang.NoClassDefFoundError: com/google/appengine/tools/util/Logging at com.google.appengine.tools.development.DevAppServerMain.main(DevAppServerMain.java:82)

What could be the problem? I’ve tried reinstalling Eclipse and reconfiguring the Build Path for a couple of times now, but no avail.

Thanks!

(This is actually a repost from my stackoverflow post, just in case this will get crawled on by people who also develop on GAE.)

Written by falloutkee

November 28, 2009 at 1:07 pm

what happened?

leave a comment »

I came to school early because the latest version of our application is stored in the imac. When I opened eclipse, it showed the welcome page, which was something that I haven’t seen in a long time. I thought that page will only pop up if we’ve just installed eclipse. When I pressed the workbench button, all our projects were gone! The project explorer was empty. Fortunately, the projects are saved in a workspace so I just proceeded to import our application.

Read the rest of this entry »

Written by janinaj

September 9, 2009 at 1:40 am

Posted in BabyBook

Tagged with , , ,

Android Device

leave a comment »

On Wednesday, I will be turning over the Android device to the lab for your testing. I will be removing the SIM (so please put in a Globe/Smart prepaid SIM – couldn’t get Sun SIM to work). Unfortunately, this device has a defective wifi radio – which will render our app testing a bit more expensive considering that we need to connect to the internet via 3G. Yeah, can’t complain since this is free. 🙂 I am still trying to procure another one for the lab – just waiting for Smart to make the HTC Magic available as prepaid.

Read the rest of this entry »

Written by rom

August 30, 2009 at 11:59 pm

Configuration Passed

with 3 comments

FINALLY!

After hours of configuring, I finally get to develop on my machine. Configuration in Java/Eclipse takes a lot of work.

Written by Paolo Sy

August 25, 2009 at 6:03 pm

Posted in Hardwire

Tagged with , ,

Total Eclipse of the Web

with 2 comments

Once upon a time, I was using Notepad (plus plus). Now, I’m gon’ be using Eclipse.

There’s nothing I can say. Eclipse is the IDE all-in-one… *fade out*

Written by Paolo Sy

August 20, 2009 at 4:50 am

Posted in Hardwire

Tagged with , , ,

First Decisions Checklist

leave a comment »

Before starting to code, we need to determine the right tools to use so we can have a smooth flowing operation. Below is a list of technologies technologies that we’ll use for Projectrix

Cloud – CHECK!

Google App Engine

Programming Language – CHECK!

Python

IDE – CHECK!

Eclipse Galileo

Framework – CHECK!

Django

SET UP EVERYTHING – Stay tuned =)

Written by Daniela

August 13, 2009 at 2:42 pm

PYTHON: Getting Started

leave a comment »

After the big reptile decision, here comes the start of serious coding and another round of research and more coding. We shall use ECLIPSE with PYDEV plugin for Projectrix. It’s quite tricky to start given we must take note that we’ll be using GOOGLE APP ENGINE too. The following links helped us set up:

http://code.google.com/appengine/articles/eclipse.html

http://code.google.com/appengine/downloads.html

http://code.google.com/eclipse/docs/download.html

http://code.google.com/eclipse/docs/install-eclipse-3.5.html

http://code.google.com/appengine/docs/python/gettingstarted/

Google rocks! =)

Written by Daniela

August 13, 2009 at 6:55 am